mod_perl2インストールメモ書き
2009/10/29(木) 19:24 覚え書きはてブ情報 はてブに登録 はてブ数

mod_perlのインストール。ちょっとつまった上に、検索してもわかりやすい手順がまとまっているページが見つからなかったのでメモしとく。CentOS4です。

1.まず、バージョン。

httpd -v
で確認。
apache1.xにはmod_perl
apache2.xにはmod_perl2と決まってる。

2.ApacheがDSO対応か確認。

httpd -l
で、「mod_so.c」 が表示される事を確認。ない場合どうするかはわかんないので調べてください。

3.Apache拡張機能を使うためにapxsが必要です。

httpd-develに入ってるのでhttpd-develごとインストールしとく。
yum install httpd-devel

4.mod_perl2をダウンロード

wget http://perl.apache.org/dist/mod_perl-2.0-current.tar.gz

5.解凍したらインストール

perl Makefile.PL MP_APXS=/path/to/apxs
make
make test
make install
途中で
 ************* WARNING *************
Your Perl is configured to link against libgdbm,
but libgdbm.so was not found.
You could just symlink it to /usr/lib64/libgdbm.so.2.0.0
 ************* WARNING *************
とか出たら/usr/lib64/以下にlibgdbm.soがないよ!ってことなのでlibgdbm.so.2.0.0へシンボリックリンクを張る。
ln -s /usr/lib64/libgdbm.so.2.0.0 /usr/lib64/libgdbm.so

Unable to determine server version, aborting.
Invalid MP_APXS specified?
と出る場合はapxsが入ってません。

For details on getting started with mod_perl 2,
   :
   :
が出ればインストールは成功です。

6.httpd.confをに設定を追記

LoadModule perl_module modules/mod_perl.so
<Files *.[好きな拡張子]>
SetHandler perl-script
PerlHandler ModPerl::Registry
PerlSendHeader On
Options +ExecCGI
</Files>
[好きな拡張子]で設定した拡張子でmod_perlが動きます。すでに.cgiがいろいろある場合は.cgiを指定すると一気にmod_perl環境になっちゃって動かなかったりすると困るので.mplとか新しい拡張子にするのも吉。

7.Apacheを再起動

再起動時にmodule perl_module is already loaded, skippingと出た場合、6.の先頭のLoadModule~~の行記述は不要。

8.適当なスクリプトで動かしてみましょう。

ちなみにmod_perlでsuExecは使えないみたいなのでスクリプトの権限は705とかその辺。

以上。
こちらも参考に。
http://d.hatena.ne.jp/masutaro/20081023/1224752242

名前:  非公開コメント   

  • TB-URL  http://blog.k52.org/0107/tb/